
                                                 

 

             

CHAPTER - 5 

WORKING WITH MICROSOFT EXCEL 

OBJECTIVES OF THIS LESSON 

This lesson is aimed to make you understand the advanced features of MS-Excel. At the end of this 

lesson the learner should be able to carry out the following the following: 

 Formatting and printing of worksheet 

 Linking of different worksheets 

 Creation and printing of charts or graphs 

 Recording and Playing Macros 

 Using built-in functions 

 

STRUCTURE OF THIS LESSON 

5.1 Introduction 

5.2 Formatting Worksheet 

 5.2.1 Standard Formatting 

 5.2.2 Conditional Formatting 

 5.2.3 Auto Formatting 

5.3 Printing Worksheet 

5.4 Establishing Worksheet Link 

5.5 Creating a Table  

5.6 Charts (Graphs) in Excel  

 5.6.1 Standard Chart Types  

 5.6.2 Creating a Chart 

 5.6.3 Adding Graphics  

5.7 Printing a Chart  

5.8 Macro 

 5.8.1 Recording a Macro 

 5.8.2 Running a Macro 

5.9 Built in Functions 

 

 Summary of the Lesson 

 Self Assessment Questions And Exercises 

    

5.1 INTRODUCTION 

Previous lesson introduced various components of MS-Excel along with the basic operations that you 

can perform while working on a worksheet. However, MS Excel provides lot of other features which 

are very useful for preparing professional worksheets. Such features include formatting, printing, 

charts, macros and built-in-functions. All these features are discussed in detail in the subsequent 

sections of this lesson. 
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5.2 FORMATTING WORKSHEET 

You can give professional look to worksheet by formatting it in many ways. Formatting is a process 

of presenting the data in an effective manner with respect to alignment, font, font size, font color, 

border pattern etc. There are many ways of formatting the worksheet; few commonly used methods 

are discussed as follows: 

 

5.2.1 Standard Formatting 

To change the font used in a cell or range of cells 

 Select the cell or range of cells you wish to change. 

 On the Excel Formatting toolbar choose a font from the Font drop down list. 

To change other font characteristics 

 Select the cell or range you wish to change. 

 From the Format menu, click Cells . 

 From the Format Cells  dialog box displayed, select the Font tab to change the Font, font 

style , or size. 

 Select the Underline: drop down list box to select a style of underline or None to remove the 

underlining. 

 Select the Color: drop down list box to choose a font color. 

 In the Effects section, you can tick Strikethrough, Superscript, or Subscript. 

 To change all the settings in the dialog box back to the Normal style which is set in the Style 

dialog box, tick the Normal font check box. 

 Select OK to close the Format Cells dialog box. 

To align data between the left and right sides of a cell 

 Select the cell, or cells, you wish to align.  

 On the Excel Formatting toolbar, click on the Align Left icon to align data with the left 

edge of the cell.  

 Click on the Align Right icon to align data with the right edge of the cell.  

 Click on the Center icon to center data in the cell. 

To align data between the top and bottom of a cell 

 Select the cell, or cells, you wish to align.  

 From the Format menu, click Cells . 

 From the Format Cells  dialog box displayed, click on the Alignment tab. 

 In the Text alignment section, choose the Top, Center, or Bottom option in the Vertical area 

to align the data in the cell. 

 To make the lines of data fit evenly within the height of a cell, tick the Justify distributed 

option and click on OK. 

 

To change the orientation of data cells 

 Select the cell, or cells, you wish to change. 
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 From the Format menu, click Cells . 

 From the Format Cells  dialog box displayed, click on the Alignment tab. 

 In the Orientation section, you can change the Degrees  of the text or use the mouse to drag 

the 'red small diamond' up or down. When satisfied, click on OK. 

 

 

To wrap multiple lines of data in a cell 

 Type the data you require into the cell and press Enter. The entry will appear as one long 

line.  Select the cell, or cells, you wish to format.  

 From the Format menu, click Cells . 

 From the Format Cells  dialog box displayed, click on the Alignment tab. 

  In the Text control section, tick the Wrap text check box and click on OK. 

To shrink the text into one cell 

 Type the data you require into the cell and press Enter.  

 From the Format menu, click Cells . 

 From the Format Cells  dialog box displayed, click on the Alignment tab. 

 In the Text control section, tick the Shrink to fit check box and click on OK. 

To merge several cells 

 Select the cells that you wish to merge to become one cell.  

 Right-click on the selected cells, click Format Cells . 

 From the Format Cells  dialog box displayed, click on the Alignment tab. 

 In the Text control section, tick the Merge cells check box and click on OK. 

Note: You also can use the Merge and Center icon on the Excel Formatting toolbar. 

To change the color of text 

 Select the cells containing the data you want to change the color.  

 On the Excel Formatting toolbar, click the down arrow next to the Font Color icon. 
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 Choose a color from the Font Color palette. 

 The color you selected from the Font Color palette will be displayed on the new icon face. 

Click on the icon face to apply the new color to the cell.  

To apply colors to cell(s)  

 Select the cell or range of cells you wish to color.  

 On the Excel Formatting toolbar, click the down arrow next to the Fill Color icon. 

  Choose a color from the Fill Color palette. 

 

To turn off the cell(s) color 

 Select the cell or range of cells you wish to color.  

 On the Excel Formatting toolbar, click the down arrow next to the Fill Color icon. 

 Choose No fill. 

To change number formatting using the formatting icons 

 We can quickly change the formatting of a cell or selected range by using the following icons 

on the Formatting toolbar.  
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Currency  12345 will become $12,345.00  

Percent  .25 will become 25%  

Comma  98765 will become 98,765.00  

Increase Decimal  12,345.00 will become 12,345.000  

Decrease Decimal  98,765.00 will become 98,765.0  

 

To format a number as a currency 

 Select the cell or range of cells you want to format.  

 From the Format menu, click Cells .  

 From the Format Cells  dialog box displayed, select the Number tab.  

 In the Category: section, select Currency.  

 
 

 

 Select the number of decimal places you require by using the Decimal places: spin box 

arrows. 

  In the Symbol: section drop down list, select the type of currency. 

  Click OK. 
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To format a number as a percentage 

 

 Select the cell or range of cells you wish to format. 

 From the Format menu, click Cells . 

 From the Format Cells  dialog box displayed, select the Number tab. 

 In the Category: section, select Percentage. 

 Select the number of decimal places you require by using the Decimal places: spin box 

arrows. 

 Click OK 

 

5.2.2 Conditional Formatting 

 

This feature helps to copy the formatting style from a selected cell to another. To do this, simply copy 

the cell and paste its format to another cell. We can also copy format to a range of cells. Following 

are the steps: 

 Select the range of cells in the worksheet to which conditional format is to be copied. The cell 

is to be copied must be the part of the range. 

 Select Format menu Conditional Formatting.  

 A dialog box will appear. 

 
 Fill the required details. 

5.2.3 Auto Formatting 

This feature is helpful to obtain professional-quality format for data. Auto formats are combinations 

of formats, such as lines and fills, that Excel applies to the indicated range of cells. Steps for Auto 

formatting are : 

 Select cell(s) in table. 

 Click Format menu, then click AutoFormat. 

 Click Premade format in Table Formats  list, to select the appropriate format. 

 Click Ok when done. 

5.3 PRINTING  WORKSHEET 

Before printing the worksheet one needs to make sure that it will appear presentable. For this printout 

orientation, scaling, margins, header and footer, and page numbering should be setup.  

 

 To Print an active document, click Print button on standard toolbar. 

 You can also click Print on File menu.  
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 You can also press Ctrl+P. 

 A dialog box will appear. 

 Fill all the necessary information and press OK. 

 
 

 

 
 

5.4 ESTABLISHING WORKSHEET LINK 

Before creating the link, format the cell containing the link formula in the destination worksheet to 

equal the format of the source data. 

1. In the source worksheet, select the cell you want to link to and click the Copy button on the 

Edit menu. Or press Ctrl+C, or right-click and select Copy. 
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2. Switch to the destination spreadsheet and click the cell where you want the link. Then, on the 

Edit menu, click Paste Special, and then click Paste Link. 

 

 

 

 

 

3. Return to the source worksheet and press ESC to remove the animated border around the cell.  
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5.5 CREATING A TABLE 

 

 Select a range of rows and columns. This range may contain values or it may be empty.  

 Click on Data menu and then choose table. 

 

 

 A dialog box will appear. Specify number of rows and columns.  
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5.6 CHARTS (GRAPHS) IN EXCEL 

 

A chart is a graphical representation of the data in your worksheet. You can create an embedded 

chart, which appears on the worksheet beside the data, or, you can create a chart sheet as a separate 

sheet in the workbook so that it can be displayed apart from its associated data. Whichever method 

you choose your chart data is automatically linked to the worksheet from which it was created. If you 

change the data on the worksheet, the chart will change accordingly.  

Excel offers many different chart types, each of which has several subtypes or variations: 

 Column 

  Bar  

 Line  

 Pie  

 XY (scatter) 

  Area  

 Doughnut  

 Radar  

 Surface 

 Bubble  

 Stock  

 Cone  

 Cylinder 

  Pyramid  

 

5.6.1 Standard Chart Types  

 

The main chart types are as follows (arranged in alphabetical order):  

 Area chart  

 

An area chart shows the relative importance of values over a period of time. It is similar to a 

line chart but emphasizes the amount of change (Magnitude of values)  rather than time and 

the rate of change.  

 

 Bar chart  

 

Bar charts illustrate comparisons between items. Although they are similar to column charts, 

the categories on a bar chart are displayed vertically and the values are organized 

horizontally. This concentrates on comparing values and places less emphasis on time. A 

stacked bar chart shows the relationship of individual items to the whole.  
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 Bubble chart  

 

A bubble chart is a variation on an xy scatter plot. The size of the bubble (data marker) 

indicates the value of a third variable. Arrange the data with x values in one column (or row) 

and the corresponding y values and bubble size in the adjacent columns (rows).  

 

 Column chart  

 

Column charts can be used to illustrate how data changes over a period of time, and to 

compare various items. Categories are displayed horizontally, values vertically.  

 

 Doughnut chart  

 

Doughnut charts are similar to pie charts but, unlike pie charts, can show more than one data 

series. Each ring represents one data series. These charts are widely used in the Far East.  

 

 Line chart  

 

This shows trends or changes in data over a period of time, at even intervals. A line chart 

emphasizes time flow and rate of change rather than the amount of change. If you need to 

show trends or changes in data at uneven or clustered intervals, an xy (scatter) chart is more 

appropriate. 

 

 Pie chart  

 

A pie chart can only show one data series. It compares the size of  individual items with the 

sum of them all.  

5.6.2 Creating a Chart 

 Choose a range of data for which we want to make a chart. 

 Either Click on the Chart Wizard button on the toolbar  

Or 

Select Chart from the Insert menu.  

 

The first Chart Wizard dialog box will appear. The Chart Wizard –  

Step 1 of 4 – Chart Type dialog box that appears has two tabs. The popular built-in chart types can be 

found on the Standard Types tab. Chart types designed by us, the user, and combination charts 

designed by Excel, can be found on the Custom Types tab.  
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Step 2 of 4 – Specify the data to be plotted i.e. the source of data for which chart is to be created. 
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Step 3 of 4 – The number of tabs displayed in the Step 3 – Chart Options window varies, depending 

on the chart type. Here we have three options— Titles, Legend and Data Labels. 

 
Step 4 of 4 – Specify chart location in window, we can specify where this new chart is to go. You can 

choose to place the chart. 

 
 

• As new sheet in which case a chart sheet containing just the chart will be entered in workbook — 

type a name for the sheet in the adjacent box.  

• As object is so that the chart will be placed in an existing worksheet  

— the current one where our data is, or a different one (click on the down-arrow to select one).  

5.6.3 Adding Graphics  

Graphics can easily be added to charts and are a useful way to draw attention to a particular feature or 

to provide an explanation. We may decide to add an arrow and some text to chart. Whatever we are 

doing, you should first make sure that the Drawing toolbar is visible:  
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Select View | Toolbars | Drawing 

There are two possible scenarios:  

• The graphics are confined to the area of the chart  

• The graphics are partly/completely outside the chart area  

Adding graphics  

 Click on the chart to select it.  

 Click on the Arrow button on the Drawing toolbar.  

 Draw an arrow on your chart.  

If the graphics are confined to the area of the chart, we can move the chart and the arrow  will move 

with it. If the graphics are partly outside the chart area, the arrow will not move with the chart unless 

we also:  

 Select the chart, arrow and text box (using Shift+click).  

 Right-click on this selection.  

 Select Grouping | Group.  

 Click away from the selection.  

5.7 PRINTING A CHART 

 To print a chart that is on a separate chart sheet, Activate the chart sheet and print as usual.  

 To print a chart that is an object on a worksheet 

1. Select the chart and choose File | Print — the chart will be printed  

             on its own. Or  

2. Select an area of the worksheet containing the chart; choose 

             File | Print and change the Print what setting to Selection — the chart  

             will be printed together with the worksheet cells that were selected.  

 

5.8 MACRO 

A macro is a set of instructions that tells Microsoft Excel to perform one or more actions as per user 

requirements. Macros are like computer programs, but they run completely within Excel. We can use 

them to automate tedious or frequently repeated tasks. 

Macros can carry out sequences of actions much more quickly. For example, we can create a macro 

that enters a series of dates across one row of a worksheet, centers the date in each cell, and then 

applies border format to the row. Or we can create a macro that defines special pr int settings in the 

Page Setup dialog box and then prints the document.  

Macros can be simple or extremely complex. They can also be interactive; that is, we can write 

macros that request information from the user and then act on that information.  

There are two ways to create a macro: we can record it, or we can build it by entering instructions in a 

module. Either way, the instructions are encoded in the programming language Microsoft Visual 

Basic for Applications (VBA).  

 

5.8.1 Recording a Macro 

 On the Tools menu, point to Macro, and then select Record New Macro.  

 In the Macro name box, enter the name of the macro. Click Ok. 

 A Stop Recording toolbar will appear. Drag it to a new position if it is in the way.  

 Perform actions we want to record. 

 Press stop recording on toolbar. A macro will be saved. 
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5.8.2 Running a Macro 

 Click on Tools menu, select Macro. 

 A list of macros, earlier saved will appear. Choose macro we want to run.  

 Click Run. 

 

 

5.9  BUILT IN FUNCTIONS 

Functions are power tools which help to perform calculations on data. FUNCTIONS are predefined 

formulas that will calculate selected data.  The user has to simply provide the values based upon 

which calculations are to be done. All Excel functions consist of three (3) parts: The = sign, the 

function name, and an argument or range enclosed in parentheses. 

A FUNCTION is always identified by the  =SIGN preceding the function name. The FUNCTION 

NAME indicates which function is being used. The ARGUMENT or RANGE is enclosed in 

parentheses and specifies the range of cells on which the function will act. The ARGUMENT can be 

a real number, a reference to a cell, a reference to a group of cells, a formula, or another function. A 

function can be added to the worksheet by two methods: 

1. Place the cursor where you want the function result to appear and select Function from Insert 

menu. 
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2. Manually type the function at desired place. 

 

 

 

 

 

 

 

Functions are characterized by purpose. There are 9 function categories.  

1. Mathematical Functions 

 With math and trigonometry functions, we can perform simple and complex mathematical 

calculations  

 

- SUM (Range)- Sum of a group of numbers  

- SQRT(X) - Displays the square root of a number (X)  

- PRODUCT (range) – multiplication of given values 

- MODE (argument 1, argument 2) – will give remainder after dividing argument 1 by 

argument 2 

 

2. Statistical Functions 

Statistical worksheet functions perform statistical analysis on ranges of data. This includes 

average, highest and lowest values, standard deviation, median, and other statistics.  

- AVERAGE (Range) - Gives the average of a group of numbers  

- COUNT (Range) - Counts the items in a list  

- MIN (Range) - Displays the smallest number in the range  

- MAX (Range) - Displays the largest number in the range  

 

3. Financial Functions   

Financial functions perform common business calculations, such as determining the payment for  

a loan, the future value or net present value of an investment,  the principle and interest etc. 

- FV – To calculate future value of investment 

- IPMT – to find interest payment 

 

4. Logical Functions 

Logical functions are used to see whether a condition is true or false or to check for multiple 

conditions. Like, 

- AND 

- OR 

- NOT 

- IF 

5. Lookup Functions 

 When we need to find values in lists or tables or when you need to find the reference of a cell, 

we can use the lookup and reference worksheet functions.  

- ADDRESS -  returns a cell reference as text 

- COLUMN – returns the column number of reference 

- COLUMNS – returns number of columns in a array of reference 
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6. Text Functions 

 With text functions, we can manipulate text strings in formulas. For example, we can change the 

case or determine the length of a text string. We can also join, or concatenate, a date to a text 

string. To manipulate the text, excel provides many functions like  

- CHAR 

- CODE  

- FIND 

- LEFT  

- LEN 

- LOWER  

- REPLACE  

- RIGHT  

- SEARCH 

 

7. Date & Time Functions 

 With date and time functions, we can analyze and work with date and time values in formulas. 

For example, if we need to use the current date in a formula, use the TODAY worksheet function, 

which returns the current date based on computer's system clock. There are other main function 

like  

- DATE 

- DAY  

- MONTH 

- NOW  

- TIME  

- YEAR 

 

8. Engineering Functions: The engineering worksheet functions perform engineering analysis.  

 

9. Database Functions: A set of functions that allows calculations on database. Following are 

the functions: 

DAVERAGE – returns the average of values in a list or database. 

DCOUNT – counts the cells in a record that matches a specified condition 

DMAX – returns the maximum value from the list or database 

DMIN – returns the minimum value from the list or database 
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SUMMARY OF THE LESSON 

 

You learnt the following in this lesson: 

 Formatting is done to give the professional look to worksheet. 

 Charts can be created easily with the help of chart wizard. 

 In Excel all formula begin with the (=) equal sign. 

 Function is a built in formula in Excel. 

 All elements of a chart can be alter after creating it.  

 Macro facility is also available in MS-Excel. These are called to speed up any general editing 

sequence that a user executes in Excel spreadsheet. 

 Data can be represented in graphical format using chart or graph option.  

 Worksheets can be linked using hyperlink command.  

 MS-Excel provides various built-in functions for different purposes such as mathematical 

functions, statistical functions, logical functions etc. 

 Numbers can be formatted in date, time, currency and scientific notations.  
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SELF ASSESSMENT QUESTIONS AND EXERCISES 

 

11. How different worksheets can be linked with each other? 

12. How worksheet functions can be categorized? 

13. Write the structure of the Function.  

14. Discuss various logical and statistical functions. 

15. State the purpose of different mathematical functions.  

16. How charts or graphs can be created in MS-Excel? 

17. Write the steps to print a graph or chart. 

18. What is the use of ‗Macros‘ in MS-Excel? 

19. Explain the steps to Record and Run a Macro. 

20. What is the advantage of using keyboard shortcuts? 

21. What is column chart? 

22. What do you mean by sum function? 

23. What is count function? 

24. Write the steps to use Average( ) function. 

25. What is the purpose of SQRT ( ) function?     
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